[FIXED] No Symbols For Paired Apple Watch iOS 9 / watchOS 2 / Xcode 7 [Beta 5]

I’m trying to get my watchOS 2 app running on my Apple Watch.

With Beta 4, I was able to run the WatchKit App (including HealthKit) and debug it on the Watch.

When upgrading to Beta 5, I couldn’t select the “iPhone + Apple watch” combination, as it was marked as Ineligible in the Active Scheme, with the following message  “xxx iPhone + yyy Apple Watch (no symbols for paired apple watch)”.

After many hours of trials and mainly errors, the solution that eventually worked for me is based on this post, but to simplify things I’ve followed the initial steps, changed the directory name to work with Beta 5 and zipped the relevant folders. So the simplified version for Beta 5 is:

  1. Download the zip file from here to the target directory:
    ~/Users/<user>/Library/Developer/Xcode
  2. Unzip the file. You should see a new folder named “WatchOS DeviceSupport” under your Xcode folder, with another folder named “2.0 (13S5325c)”.

XcodeBugFolderStructure

  1. Open project on Xcode 7 beta.
  2. Disconnect and connect your iPhone.

That’s all – it worked for me, I hope it will work for you as well.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s